Supported browsers for Yahoo Mail

Yahoo Mail supports these JavaScript enabled browsers

  • Mac OS X 10.4, 10.5, and 10.6:
    • Firefox version 19 and newer
    • Safari version 4.0 and newer
    • Google Chrome version 25 and newer

We recommend upgrading your browser

Although Yahoo Mail supports all browsers noted above, we recommend you upgrade your browser to its latest non-beta version for the optimal Yahoo Mail experience, including:

  • Faster speed: Newer browsers are faster than ever.
  • Safer protection: Viruses and spyware don't stand a chance.

Download the latest browser versions

  Good to know:

When you access Yahoo Mail you may be prompted to use basic mail--a simplified version of Yahoo Mail that does not include all features, if you:

 

  • Was this article helpful?

  • Yes
  • No

Still need help?