Which PHP functions does Yahoo support?

Yahoo supports PHP 4 and 5. The functions supported depend on which version you are using with your site; we recommend running PHP 5+.

Learn how to switch versions.

For more information about PHP functions, see the Function Reference section of the PHP Documentation Group's PHP Manual.

See additional functions new to PHP 5 and deprecated in PHP 5.3.

slide left to see more

Function PHP 4.3.11 PHP 5.2.12 PHP 5.3.6
PHP Core Y Y Y
bcmatch N Y Y
calendar N Y Y
cgi-fcgi n/a Y Y
ctype N Y Y
curl Y Y Y
date n/a Y Y
dba Y Y Y
domxml Y Y Y
ereg N N Y
exif Y Y Y
fileinfo N N Y (new)
filter n/a Y Y
gd Y Y Y
gettext N Y Y
hash n/a Y Y
iconv Y Y Y
json n/a Y Y
libxml n/a Y Y
mbstring Y Y Y
mcrypt Y Y Y
mhash Y Y Y
mime_magic Y Y N
ming Y Y N
mysql Y (v4) Y (v4) Y (v5)
mysqli n/a Y Y (v5)
openssl Y Y Y
overload N n/a n/a
pcre Y Y Y
PDO n/a Y Y
pdo_mysql n/a Y Y
pdo_sqlite n/a Y Y
Phar N N Y (new)
pspell Y Y Y
Reflection n/a Y Y
session Y Y Y
SimpleXML n/a Y Y
SPL n/a Y Y
SQLite n/a Y Y
sqlite3 N N Y (new)
standard Y Y Y
tokenizer N Y Y
wddx Y Y Y
xml Y Y Y
xmlreader n/a Y Y
xmlrpc Y Y Y
xmlwriter n/a Y Y
xslt Y Y Y
zip Y N Y
zlib Y Y Y
  • Was this article helpful?

  • Yes
  • No

Still need help?