Which version of PHP does Yahoo support?

Yahoo supports PHP 4 and PHP 5.

We recommend that you run the latest version of PHP available. Although we have reinforced our system to ensure that PHP 4 runs safely, PHP 5 is generally considered more secure and best supports modern applications and scripts.

To use MySQL 5, you'll need to be running PHP version 5.3.6 or higher. This version of PHP allows you to use the most up-to-date and secure add-ons as well as advanced scripting not available to earlier versions of PHP. 

  Note: Be sure to upgrade PHP to 5.3.6 or higher before you begin upgrading your database.

For the most up-to-date information on the current state of PHP, including version and environment information, use the phpinfo() function.

Insert the following function into a PHP file:

phpinfo();

?> 

To identify which version of PHP you are currently running:

  1. Go to the Create & Update tab of your Web Hosting Control Panel
  2. Expand the Other Site Building Tools module
  3. Under PHP Version, you'll see your current PHP version.
  • Was this article helpful?

  • Yes
  • No

Still need help?