Error message: You need to have JavaScript enabled in order to use Yahoo Mail

The new Yahoo Mail requires JavaScript to work correctly. If you do not have JavaScript enabled for your browser when you upgrade, you may receive the following message:

“You need to have JavaScript enabled in order to use Yahoo Mail.”

To learn how to enable JavaScript, please visit our help page, which includes instructions for most common browsers. 

If you cannot enable JavaScript, you also have the option to return to your original Yahoo Mail, either just for one session or more permanently. To do so, click either “Just this one time, go to your original Mail” or “Return to your original Yahoo Mail” within the error message text.

  • Was this article helpful?

  • Yes
  • No

Still need help?