Error: "Server Unavailable" when accessing Yahoo! on iPhone, iPad, iPod Touch
Cause
- Recent updates to Apple's iOS 6 have caused the configuration settings of the Mail app to malfunction.
- The Description field in the app's settings is set to something other than your full email address.
Resolution
Often, you may remove and re-add Yahoo! Mail to resolve this. Ensure that you use your full email address in the Description field while reconfiguring your account. If the issue persists, remove Yahoo! Mail again and then re-add it using these alternate steps:
- Tap Settings | Mail, Contacts, Calendars.
- Tap Add Account... | Other | Add Mail Account.
- Enter your name, full email address, password, and your full email address in the Description field, then tap Next.
- Ensure IMAP is selected at the top, then enter the following:
- Incoming Mail Server:
- Host Name: imap.mail.yahoo.com.
- Username: your Yahoo! ID
- Password: your account password
- Outgoing Mail Server:
- Host Name: smtp.mail.yahoo.com.
- Username: your Yahoo! ID
- Password: your account password
- Incoming Mail Server:
- Tap Next. If you select to use SSL, please enter the following:
- Outgoing Port: 465 (requires SSL)
- Alternatively, you can enable SSL/TLS and type 587.
- It is necessary to enable SSL or TLS for Outgoing SMTP server.
- Incoming Port: 993 (requires SSL)
- Outgoing Port: 465 (requires SSL)
- Ensure that Mail is set to ON, then tap Save.
Additional Information
Please note: The alternate steps above only allow you to sync Mail and Notes. If you wish to add your Yahoo! Calendar and Contacts to your phone, you will need to do so separately.
To sync your Calendar:
- Tap Settings | Mail, Contacts, Calendars.
- Tap Add Account | Other | Add CalDAV Account.
- Enter the following information:
- Server: https://caldav.calendar.yahoo.com
- User Name: your full email address
- Password: your account password
- Description: your full email address
- Tap Next.
To sync your contacts, configure your contacts using the CardDAV account settings.