Troubleshooting steps for images not loading on a Yahoo! site
Description
Images and photos are not displaying or appearing on Yahoo! pages.
Cause
There are two possible causes:
- Your internet browser's settings
- Interference from some types of Internet security software
Resolution
Problems with a specific image:
If you are having problems with a specific image, click the Refresh or Reload button on your browser.
Problems with all images:
If images aren't loading when you visit a Yahoo! site, you should check your browser's image display settings. Select your browser from the list below for complete steps:
Internet Explorer 7.0 or newer:
- Click Tools | Internet Options.
- Click Advanced.
- Under the "Settings" list, locate Multimedia.
- Check the checkbox for Show Pictures.
- Click OK.
- Close and restart your browser.
- Choose the menu option for your computer:
- PC Windows: Click Tools | Options.
- Mac OS X: Click Firefox | Preferences. - Select Content.
- Check the checkbox for Load images automatically.
- Click OK.
- Close and restart your browser.
- Choose the menu option for your computer:
- PC Windows: Click Tools (
gear icon) | Preferences.
- Mac OS X: Click Safari (
gear icon) | Preferences.
- Select Appearance.
- Check the checkbox for Display images when the page opens.
- Close the "Settings" pane.
- Close and restart your browser.
- Choose the menu option for your computer:
- PC: Click Tools (
wrench icon) | Options.
- Mac OS X: Click Tools (
wrench icon) | Preferences.
- Mac Chromebook: Click Tools (
wrench icon) | Settings.
- Click Under the Hood.
- Click Content settings.
- Under "Images," select Show all images (recommended).
- When you are done, close the "Options - Content Settings" tab by clicking the X that displays on the tab.
- Close and restart your browser.
If you are still experiencing issues after trying the steps above:
The cause is either your computer's firewall settings or your web browser. To troubleshoot, please follow the steps below in order until the issue is resolved:
- Firewall issues: If you are behind a firewall or connecting to the Internet through a proxy server (like a business Intranet), this could also prevent images from displaying. Try turning off (or "disabling") one or both of these features. For information, see Temporarily turning off anti-virus, anti-spyware, and firewall products.
- Additional browser troubleshooting steps: If it's not a firewall issue, the cause is your browser. Each step below is designed to fix common browser issues, and you can click on the links for complete instructions as needed.
- Clear your browser's cookies and cache.
- Ensure that JavaScript is turned on and that it's updated.
- Turn off add-ons and plug-ins.
- Update Adobe Flash Player.
- Test with a different browser: Corrupted browsers can cause problems with Yahoo! sites.
- Try another Web browser to see if the issue goes away.
- Update your browser -- the most recent version will work best. Click a link to download:
- Test from another computer: Eliminate your computer as a cause of this issue by trying to access Yahoo! from another computer.