iOS device won't sync with Yahoo! Calendar
Description
Resolving sync problems between your iPhone, iPad, or iPod Touch and your Yahoo! Calendar.
Cause
Recent upgrade from either iOS 4 or iOS 5 to iOS 6 on iPhone, iPad, or iPod Touch.
Resolution
If you recently upgraded the operating system on your iOS device (iPhone, iPad, iPod Touch) to iOS 6, then that could be the cause of the syncing issues you're encountering.
By deleting and recreating the Yahoo! account on your iOS device you can force a new sync, which should bring all your information over from Yahoo!.
If you have a CalDAV account set up on your iOS device, you'll need to delete it. CalDAV accounts are no longer needed to sync your iOS device with Yahoo! Calendar. If you don't delete it, you run the risk of getting duplicate calendars and events on your iOS device and also in Yahoo! Calendar.
To delete your Yahoo! Calendar CalDAV account from your iOS device:
- Go to the "Settings" application on your iPhone, iPad, or iPod Touch.
- Tap Mail, Contacts, Calendars.
- Tap Yahoo! Calendars, Reminders.
- Or the name of the account, if you have named it. - Tap Delete Account.
- Tap Delete Account again to confirm deletion.
To sync your iOS device with your Yahoo! Calendar (and Yahoo! Contacts):
- Go to the "Settings" application on your iPhone, iPad, or iPod Touch.
- Tap Mail, Contacts, Calendars.
- Tap Add Account.
- Tap Yahoo!.
- You may already have a "Yahoo! Mail, Contacts, Reminders, and Notes" account set up.
- If you do, just tap it under the "Accounts" section. - Enter your information:
- Name
- Yahoo! email address
- Password
- You don't need to change anything in the "Description" field unless you wish to. - Tap Next after you've entered the information.
- Yahoo! will then verify your account information. - Tap Save.
- While still in "Settings" for "Mail, Contacts, Calendars":
- Set Fetch New Data to every 15 minutes (or whatever time increment you desire).
- No changes are needed to the "Push" setting: Leave the Push setting on or turn it off.
- (The Push setting isn't relevant to Yahoo! services.) - Ensure proper syncing between your iOS device's Calendar and Yahoo!:
- Check that the Default Account on your device is set to one of your individual calendars from Yahoo! Calendar in "Calendars," located near the bottom of the settings for "Mail, Contacts, and Calendars."
- (It defaults to iCloud and if not changed to one of your calendars from Yahoo! Calendar, syncing will not work.)
- If you decide to make a change in the future: You can come back to "Yahoo! Mail, Contacts, Reminders, and Notes" to disable syncing for all or specific Yahoo! Services. You can also delete your Yahoo! account from your iOS device.