How to reactivate or recover a deleted Yahoo! ID or Yahoo! Mail account
Cause
There are three possible reasons that a Yahoo! account may appear to be invalid:
- The user had requested deletion of the account. This would require entry of a valid password.
- The account was removed due to inactivity. Yahoo! Mail accounts are deactivated and removed after six months of not being used, plus an additional two months for each year you held the account.
- Yahoo! deactivated the account because of a violation of the Terms of Service.
Resolution
In some cases, it is possible to reactivate your Yahoo! Mail account; however, please know that an account cannot be recovered if it was deactivated due to a violation of the Terms of Service. Also, keep in mind that if the account was deleted more than 90 days ago, account recovery may not be possible.
To reactivate your account:
- Sign in to your Yahoo! Mail account with your current password. (We encourage you to do so on a computer rather than a mobile device.)
- Confirm your Yahoo! ID and complete the CAPTCHA verification.
- Select Reactivate at the bottom of the page.
If you are having trouble reading the CAPTCHA code, you have a couple of options:
- Select Need audio assistance? above the CAPTCHA to hear the code read aloud.
- Select Can't read this code? below the CAPTCHA to see a different code.
The reactivation can take up to 24 hours and some account data may be lost before the account is reactivated.
Yahoo! Mail Plus (or Yahoo! Mail Premium) accounts are protected from dormancy and are not subject to deactivation due to inactivity. Please visit our Yahoo! Mail Plus page to learn more and sign up. (Yahoo! Mail Plus accounts are not available in all regions.)
Note: If you don't know why your account was deleted, there's a chance that a third party deactivated it. As a result, we recommend that you change your password to protect the security of your account. For useful information and resources regarding online security, please visit the Yahoo! Security Center. Please note also that this process needs to be completed on a desktop or laptop computer as most mobile devices do not support reactivation.
Additional Information
Please note that the Yahoo! Terms of Service and privacy policies vary by country. Find information for other countries.
