I've checked the "Keep Me Signed In" box. Why am I still asked to sign in?
ID: SLN2660
Refers to:
Yahoo! Account
,
Finance
,
Groups
,
Mail
,
Mail Classic
,
Mobile Mail
,
Homepage
,
Games
,
Toolbar
,
My Yahoo!
Cause
You may be getting this prompt if:
- Your browser auto-fill is disabled
- Your browser auto-fill has the wrong information
- If persistent log in is not set up correctly
Resolution
When you are signed in to your Yahoo! account, you may be prompted to sign in again under the following circumstances:
Account sign-in prompt troubleshooting:
- Clicking "Sign Out":
- You may have accidentally clicked Sign Out.
- Going to the Account Info page:
- For your security, we always prompt you for your password when accessing sensitive information.
- Changing your sign-in settings in Account Info:
- If you modified "Change sign in setting" on your Account Info page, you may have reset the amount of time before Yahoo! asks you to re-enter your password.
- Follow these steps to check this setting for your account:
- Sign in to Yahoo!.
- Click the down arrow next to your name, and select Account Info.

- The Account Info page opens.
Note: If prompted, re-enter your password and click Sign-In.
- Under "Sign-In and Security," click Change sign-in settings.

- The "Change sign-in settings" form opens.

- From the Sign me out every menu, select either:
- day: If you select "day," Yahoo! overrides the amount of time that you remain signed in using the "Keep me signed in for 2 weeks" option on the Sign-In page. In 24 hours, Yahoo! automatically signs you out.
- 2 weeks: If you select "2 weeks," you'll stay signed in for two weeks. - Click Save.
- Signing in to a different Yahoo! account in a new browser window or tab:
- Opening another browser window or tab and signing in to a second Yahoo! account will automatically sign you out of the first account.
- When you return to the first account, clicking any link may give you the "Your login session has expired" message.
- To sign in to two different accounts at the same time, use two different browsers like Internet Explorer and Firefox.
- Using browser extensions and/or security software that clear cookies automatically:
- Some browsers and security programs clear sign-in cookies each time you close your browser, causing you to have to sign in again when you re-open your browser. (An example is the program Webroot Window Washer.)
- To use the "Keep me signed in" setting, you'll need to disable ("turn off") or uninstall these security programs. For information, see Temporarily turning off anti-virus, anti-spyware, and firewall products.
- Another option is to modify their settings to prevent them from deleting cookies for the yahoo.com domain. For information about modifying these settings, please refer to the product's help file.
- Manually clearing cookies from your computer:
- Manually deleting cookies from your browser will remove the cookies that keep you signed in to Yahoo!.
- Your browser is automatically clearing cookies or the cookie file has been corrupted:
- Verify whether your browser is automatically clearing cookies. For information, see How to check if your browser is automatically clearing cookies.
- If your cookie files have become corrupted, you need to clear your cookies. For information, see How to clear your browser's cookies and cache.
- We recommend using a current version of your browser, to get the latest version click the link for your browser:
* Microsoft Internet Explorer
* Mozilla Firefox
* Apple Safari
* Google Chrome